June 24, 2007

Giving Moodle the boot



Tried to upgrade my Moodle installs from 1.6.1 to 1.8 (what Fantastico was suggesting). Fantastico had no problem, but all kinds of problems showed up when I visited those Moodle sites and tried to start the upgrade process. In one case, Moodle told me it couldn't even FIND the directory I was pointing it at. In another, there was some problem with the title or something. In all of these, tho, I had to install UTF-8 encode, for instructions on which I should go to the "Admin page". Which admin page? I can't get INTO my moodle site because this damn "Do you want to upgrade" window pops up all the time and won't go away.

OK, pop over to the old Moodle.org and take a gander to see if I can find out how this UTF-8 transfer thing happens. Do you think I can find a page of simple instructions on this within, say, an hour? DO YOU?!?!? One page says do the transfer AFTER you upgrade, another says you must do it BEFORE you upgrade. In any case, there is no "UTF-8 transfer" button (or anything like it) on my Admin navigation bar.

It's the usual story: batted from pillar to post, from "documentation" to "installation" to "Installation FAQ". In between the search, it's time for dinner. Afterwards, somewhat refreshed, I try again. After more pointless running around in circles like being trapped in some porn site, I see the light: I return to "Installation FAQ" and click on "How to uninstall Moodle?"

A mere 5 minutes later and my troubles are over. Moodle has wasted more than enough of my time. Not any more. Blessed release!

5 comments:

Gary said...

HI,

My experience with Moodle upgrades is that you can / should only do point release upgrades ... ie 1.6* -> 1.7*, then 1.7* ->1.8* and so on.

This is a common practice is many software systems.

Having had the very same experience you describe ( varies depending upon the actual additional modules you have loaded ), and then reverting to point release upgrades, I've had no problems since.

HTH

Gary Benner
123 Internet Ltd

Marco Polo said...

Gary is of course right. But frankly, the whole experience was too geeky for me. I mean, there's Fantastico, inviting me to click and upgrade from 1.6.1 to 1.8. Do I really want to upgrade manually? I wouldn't even know where to start, which would necessitate more hours delving into the labyrinth of Moodle documentation. Sorry. Moodle can do lots of neat things, but I just don't have the time to spend on maintaining it. (Having said that, I might do a fresh install of 1.8 and give it one more try, but that will be its last chance. Honest.)

Catherine said...

I'd like to offer to let you use our LMS instead. It's called Scholar360 and it combines all the academic features you will need with a social network that I think your students will love. Go to http://www.scholar360.com.

EFL Geek said...

Marco,

The upgrade to utf-8 for moodle was particularly troublesome. It's usually not that difficult. I would also like to say that fantastico is not fantastic is likely to screw up installs/upgrades of scripts and is usually several bug fixes behind on the scripts you have options for.

manual is best and it really only takes about an hour. For me I only install/upgrade during vacation. This way I have time to troubleshoot if there are any unforeseen difficulties.

catherine, I'll go check out that site you listed now.

Marco Polo said...

Thanks for all the comments, Gary, EFL Geek and Catherine (smart move, Catherine, will give it your plugged product a spin once classes finish in late July). I wrote that Gary is right about upgrading Moodle in point release upgrades, but actually even that did not work smoothly at all, and gave rise to my first big Moodle whine about a year ago. Moodle is an impressive piece of software; it just requires a more geeky kind of person than I am (someone with more time and technical know-how than I have or want) to maintain it in smooth working order. I want my life back, and Moodle is just one of several things that are getting the boot.